插件 SDK 下载

当前版本

X-Plane SDK 下载包含用于编译插件的 C 头和 pascal 接口文件,以及用于链接需要插件的平台的存根库。你不需要下载任何文件来运行插件; X-Plane 附带了适当的基础设施来托管插件。

适用于 Windows 、 Linux 和 Mac ZIP 的 X-Plane SDK 3.0.1

无论您针对哪个 X 平面版本,您都可以并且应该下载上面的最新 SDK 文件。为了支持 X-Plane 的其他版本,您只需要更改项目定义的 XPLM 宏,如下所示:

  • XPLM301-X-平面 11.20 & 更新 (仅 64 位)
  • XPLM300-X-平面 11.10 & 更新 (仅 64 位)
  • XPLM210-X 平面 10.00 和更新 (64 位插件需要 10.20)
  • XPLM200-X-飞机 9.00 & 更新
  • 没有XPLMxxx定义-X-平面 6.70 & 更新版本

请注意,这些定义不会自动暗示旧版本-因此,要将 X-Plane 11.20 与所有最新功能瞄准,您需要定义全部XPLM301,XPLM300,XPLM210,和XPLM200

旧版本

以下是仅用于传统目的的旧 SDK 版本。你不应该需要它们。使用上面最新的 SDK 来构建所有插件,即使是针对旧版本的 sim卡。